Samsung Issues Critical Galaxy S And Galaxy Note Warning For 40 Million Users

Samsung has this week confirmed security vulnerabilities that affect Galaxy S8, S9, S10, S10e, S10 Plus, S10 5G, Note 9, Note 10 and Note 10 Plus users. Amongst these is a critical vulnerability and three that are rated as “high.” In all, there are some 21 security issues covered; 17 related to Samsung’s “One” user interface and four concerning Android. Here’s what you need to know and what you need to do now.

The Samsung Galaxy specific security warnings

The latest Samsung security maintenance release (SMR) has also now started to roll out to users of Galaxy devices across the product range. The October SMR includes patches from Google, which affect Galaxy 10 users as well as those with earlier devices from Samsung. There are also a whole bunch of vulnerabilities that specifically impact Galaxy 8 and Galaxy 9 device users. Amongst these, there is a Galaxy 9 vulnerability that is rated as being critical: SVE-2019-15435. This affects both the Galaxy S9 and Note 9, although details are sketchy as to the exact technical nature of the vulnerability as it has been “privately disclosed” to protect users until patches are installed. With around 30 million Galaxy 9 smartphones sold, and another 10 million Galaxy Note 9 devices, that’s a potential 40 million users who need to take notice of this warning.


See full article below from Forbes

https://www.forbes.com/sites/daveywinder/2019/10/09/samsung-issues-critical-galaxy-and-note-warning-for-40-million-users/#124708bf669a